hostapd and wpa_supplicant: Denial of Service — GLSA 201908-25

A vulnerability in hostapd and wpa_supplicant could lead to a Denial of Service condition.

Affected packages

net-wireless/hostapd on all architectures
Affected versions < 2.8
Unaffected versions >= 2.8
net-wireless/wpa_supplicant on all architectures
Affected versions < 2.8
Unaffected versions >= 2.8

Background

wpa_supplicant is a WPA Supplicant with support for WPA and WPA2 (IEEE 802.11i / RSN).

hostapd is a user space daemon for access point and authentication servers.

Description

A vulnerability was discovered in hostapd’s and wpa_supplicant’s eap_server/eap_server_pwd.c and eap_peer/eap_pwd.c files.

Impact

An attacker could cause a possible Denial of Service condition.

Workaround

There is no known workaround at this time.

Resolution

All hostapd users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-wireless/hostapd-2.8"
 

All wpa_supplicant users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-wireless/wpa_supplicant-2.8"
 

References

Release date
August 18, 2019

Latest revision
August 18, 2019: 1

Severity
normal

Exploitable
remote

Bugzilla entries