PHP: Multiple vulnerabilities — GLSA 202003-57

Multiple vulnerabilities have been found in PHP, the worst of which could result in the execution of arbitrary shell commands.

Affected packages

dev-lang/php on all architectures
Affected versions < 7.4.4
Unaffected versions revision >= 7.2.29
revision >= 7.3.16
revision >= 7.4.4

Background

PHP is an open source general-purpose scripting language that is especially suited for web development.

Description

Multiple vulnerabilities have been discovered in PHP. Please review the CVE identifiers referenced below for details.

Impact

An attacker could possibly execute arbitrary shell commands, cause a Denial of Service condition or obtain sensitive information.

Workaround

There is no known workaround at this time.

Resolution

All PHP 7.2.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-7.2.29"
 

All PHP 7.3.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-7.3.16"
 

All PHP 7.4.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-7.4.4"
 

References

Release date
March 26, 2020

Latest revision
March 26, 2020: 1

Severity
high

Exploitable
local, remote

Bugzilla entries