Multiple vulnerabilities have been found in QtCore, the worst of which could result in the execution of arbitrary code.
|Package||dev-qt/qtcore on all architectures|
|Affected versions||< 5.13.2-r2|
|Unaffected versions||revision >= 5.12.3-r2
revision >= 5.13.2-r2
The Qt toolkit is a comprehensive C++ application development framework.
Multiple vulnerabilities have been discovered in QtCore. Please review the CVE identifiers referenced below for details.
An attacker could possibly execute arbitrary code with the privileges of the process or cause a Denial of Service condition.
There is no known workaround at this time.
All QtCore 5.12.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-qt/qtcore-5.12.3-r2"
All QtCore 5.13.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-qt/qtcore-5.13.2-r2"