Multiple vulnerabilities were found in OpenSSL, the worst of which could allow remote attackers to cause a Denial of Service condition.
|Package||dev-libs/openssl on all architectures|
|Affected versions||< 1.1.1g|
|Unaffected versions||>= 1.1.1g|
OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1/v1.1/v1.2/v1.3) as well as a general purpose cryptography library.
Multiple vulnerabilities have been discovered in OpenSSL. Please review the CVE identifiers referenced below for details.
A remote attacker could perform a malicious crafted TLS 1.3 handshake against an application using OpenSSL, possibly resulting in a Denial of Service condition.
In addition, it’s feasible that an attacker might attack DH512.
There is no known workaround at this time.
All OpenSSL users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.1.1g"