GNU C Library: Multiple Vulnerabilities — GLSA 202208-24

Multiple vulnerabilities have been discovered in the GNU C Library, the worst of which could result in denial of service.

Affected packages

sys-libs/glibc on all architectures
Affected versions < 2.34
Unaffected versions >= 2.34

Background

The GNU C library is the standard C library used by Gentoo Linux systems. It provides programs with basic facilities and interfaces to system calls. ld.so is the dynamic linker which prepares dynamically linked programs for execution by resolving runtime dependencies and related functions.

Description

Multiple vulnerabilities have been discovered in GNU C Library. Please review the CVE identifiers referenced below for details.

Impact

Please review the referenced CVE identifiers for details.

Workaround

There is no known workaround at this time.

Resolution

All GNU C Library users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=sys-libs/glibc-2.34-r7"
 

References

Release date
August 14, 2022

Latest revision
August 14, 2022: 1

Severity
normal

Exploitable
remote

Bugzilla entries